SERVER 2 Not allowing registration

  • Been up since 5am as per server start time and there is no option to register for server 2. What a total farce and no way to run a business. You'd think after at least ten years at this game the Travian techies could at least get this basic function right, it's almost as if they don't want our money. Nothing about it from Trav team at all, no info, nothing. Disgrace

    Gaming since 1976. Travian since 2007. Genius since the day I was born.

    Boxxx ANGLO 1 Unfairly Banned

  • people have successfully registered. Please give us more details on the issue you are having.

    Dont forget to clear cookies and cache

    Use if you are still not able to access. The issue has been reported to HQ staff

  • Unfortunately we cant predict what will or wont work with the new homepage system. There are many known bugs but this is not one that has been experienced before.

  • The main issue for most people I think is the lack of anyone around to deal with the issue, you are the first to reply and we have all been trying to get a response from different sources since 5am

  • Memebers of the support staff have been answering tickets sent to the support box. I was informed by support that there seems to be an issue.

    I do not have access to all the support tools as im not game staff however I have reported the issue to the Customer Services Rep and to HQ. Awaiting a response on how to proceed.

    For the timing being please use registration is still possible from there

  • Emergency Ticket has been raised with HQ for:

    New homepage Registration failing
    Old Homepage activation links not being sent

    If you register using the old homepage you may still have issue and do so at your own risk

  • is there still an issue with registering? I've tried the new and old homepage and it keeps telling me the account name is already registered (have tried a few that I am sure will not be registered), or i get told the email is already registered.

  • there is not an activation email, I also thought maybe it had registered without sending the email, so I tried logging in with "forgot password" option, but i then get a message saying "email service error"