Laggy servers

  • Not much to say about this, but for the past few days anglox, comx5 and anglox5 servers been pretty much unplayable due to lag. Anglox still barely okay, but lag in x5 (especially comx5) is crazy.

    No, it is not my internet nor device i am using to browse through.

    No, clearing cache, cookies or using low bandwidth version of game does not help either.

    Some of my fellow teammates are experiencing same lag issues.

    Can Administrator give a feedback in regards to this? When x5 servers started it was okay to play, only recently lag became an issue.

    Biggest Noob of them all

  • You're not alone. Com29 is laggy for me as well. In comparison, com83 working normally. I reported it to Support already. For me this issue persists for 3-4 days.

    It's especially annoying when changing helmets, because they don't change instantly, and then I think that maybe I didn't click on it, then I click again, and then it shows that helmet is on, but when I reload the page, helmet is actually off, because I double clicked it.

    Past servers: Alfėja Baltics speed, Alfėja Baltics 2, MC Eiaiestyi comx2, Eiaiestyi com29 (x5), Ankhsi com83 (PtP Closed Beta)

  • Can confirm that COM29 (Com5x) has been running a lot better, than what it did a few days ago.


    Thanks for fixing the issue :D

  • I think that's all right. Though it seems slower than other server. But at least not that much laggy anymore. I can live with it. :D

    Past servers: Alfėja Baltics speed, Alfėja Baltics 2, MC Eiaiestyi comx2, Eiaiestyi com29 (x5), Ankhsi com83 (PtP Closed Beta)