registration and activation problem

Would you like to know what’s going on in the Tournament 2017 Finals?
Keep yourself updated by reading "The Corner"!

  • registration and activation problem

    Happened on Czech speed server but I guess its global bug. This system is not well designed in my opinion. Why cant users specify their passwords while registering new account. Its possible only during activation, which can fail and thats my problem I will describe. I have activated my account(chose side and submitted) but due to some issue the welcome screen of my village didnt show up and browser stayed on blank page.

    1. Couldnt login again because server didnt recognize my password. Apparently it wasnt associated with my account.
    2. Couldnt reuse activation link.
    3. Had to ask for password change via recieving e-mail.
    4. Changed password through another link I got in my mailbox. It said I will be informed about this change.
    5. Still couldnt log in. Recieved info. Again, couldnt log in.

    so what now? creating another account is a solution but its annoying and now I need to use different account name and e-mail address!

    I suggest to fix this problem :| also being able to specify password during registration would probably solve this problem as I would be able to either finally login and continue or specify tribe, side etc again(this used to happen before when activation failed). Or make it that way that activation link will work TILL account is REALLY activated.
  • Hello Buckyx

    Sorry to see you were having some issues.

    Try to use the old link to the Travian servers as that seems to be the work around till they sort out this register bug.

    Here is the link for that

    TRAVIAN - the online multiplayer strategy game

    Let me know if you have any problems getting on from there.
    Forum Users Guide - USER GUIDE
    Forum Rules & Guidelines - FORUM RULES
    Game Rules & Guidelines - GAME RULES