In-game Advertisements not working

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

The Tournament 2018 Qualification starts on the 13th June 2018!
Don't miss Safiren's Corner!

Dear players. Read important info about global maintenance. Please, make sure to accept new Terms and Conditions in accordance with the new GDPR law to be able to continue playing. More information here.

  • In-game Advertisements not working

    I'm currently playing on the Spanish speed server and the advertisements which let you construct faster don't work for me. Whenever I click the construct faster button the usual screen comes up but remains black. I've disabled all ad-blocking services, updated my browser and all the "adobe stuff". I've even tried different browser (currently using firefox), but to no avail. This issue only seems to happen when I'm playing on servers of other languages (does for example not happen on the international or UK servers).
    Is anyone familiar with this issue or have any input regarding a solution? Thanks
  • Advertising is targeted to an extent so that possibly might be why you cant see all videos (its not cost effective to display something local to spain to users from the UK) but you should still see the internal TravianGames marketing videos (UnitedGP & GoalUnited seem to be the most common)

    Please send a message to the multihunter as they can send it directly to the relevant team.

    If you look to the top left of the video popup you may see 4 or 6 digit number(s) if you can note them also as it will help the video providers identify the issue.
    128-10-93-85-10-128-98-112-6-6-25-126-39-1-68-78

    Game Rules | Terms & Conditions | Rules FAQ

    Game issues can only be answered by sending an In-Game Message to Multihunter / Support
    Or via the Homepage Support form
  • playingwithfire wrote:

    Have you reported this in game yet first of all?

    I know that on another game I play that also has the option to watch videos, I have no issues when the videos are in another language. But I am a Mac user and that sometimes seems to be the difference.
    No, I have not reported it in-game, but I will do that now. Yeah, it's weird...
  • Arthur Dent wrote:

    Advertising is targeted to an extent so that possibly might be why you cant see all videos (its not cost effective to display something local to spain to users from the UK) but you should still see the internal TravianGames marketing videos (UnitedGP & GoalUnited seem to be the most common)

    Please send a message to the multihunter as they can send it directly to the relevant team.

    If you look to the top left of the video popup you may see 4 or 6 digit number(s) if you can note them also as it will help the video providers identify the issue.
    Yes, that could be possible, but I'm not even able to see the standard videos (the ones you mentioned). But I will contact a multihunter, tell him about the issue and also provide the digits as you said, so thanks for your answer.
  • babylon wrote:

    I've disabled all ad-blocking services

    thesssssupdude_UK wrote:

    i think u might have adblocker on

    babylon wrote:

    I made sure that ad-block is turned off..

    thesssssupdude_UK wrote:

    Maybe u didnt turn adblock off...
    Dude. He turned off adblock. He told us twice.

    Doesn't work consistently for me either and I also do not have adblock on. I just open and wait for a few minutes until I finally get a car commercial on half of the screen with Goal United voiceover.
  • kit wrote:

    babylon wrote:

    I've disabled all ad-blocking services

    thesssssupdude_UK wrote:

    i think u might have adblocker on

    babylon wrote:

    I made sure that ad-block is turned off..

    thesssssupdude_UK wrote:

    Maybe u didnt turn adblock off...
    Dude. He turned off adblock. He told us twice.
    Doesn't work consistently for me either and I also do not have adblock on. I just open and wait for a few minutes until I finally get a car commercial on half of the screen with Goal United voiceover.
    Have you turned adblock off?
    ukx - MadZ (Hegemony) | Danny Zuko (GTB)
    uk1 - David Brent (MFH)
  • kit wrote:

    Doesn't work consistently for me either and I also do not have adblock on. I just open and wait for a few minutes until I finally get a car commercial on half of the screen with Goal United voiceover.
    I have had the half the screen video and the wrong voice over on Rail Nation. So it sounds like it is an issue on multiple games. And yes, I am just as guilty of not reporting them.

    Forum User Guide
    Please contact in game Support for in game issues.
  • Where other bugs can be reported? for example after the latest update:
    T4.4 (Adventure) Patch Release 49
    Monday, 12:00am


    Marketplace is completely messed up. :thumbdown:

    When i select the destination village for sending resources, i need to type 3 letters instead of 2 to pop up the auto-complete.
    After i sent resources to that village, and select the next village to send resources from, i have to type the co-ords again and again for every single village i send resources from. This is driving me nuts.

    Dear Travian developers, please fix this!

    In exchange i have new icons for the tribes in the alliance page....
    What was wrong with the old ones???????

    Marketplace is an important part of the game, yet not taken seriously by travian team. i need a game that is reliable and fully working. i don't care what cosmetics takes place with resources fields pictures or the tribes icons, as long as everything works the way it use to be.
  • Mysterious Stranger wrote:

    Marketplace is completely messed up. :thumbdown:

    When i select the destination village for sending resources, i need to type 3 letters instead of 2 to pop up the auto-complete.
    After i sent resources to that village, and select the next village to send resources from, i have to type the co-ords again and again for every single village i send resources from. This is driving me nuts.
    Edit your village names, so instead of being 01Something, add a space so name now becomes 01 Something, the space acts as the 3rd character and should bring up your village name.


  • I don't want to edit my villages names at all. I want Travian team to fix up their mess. it was working perfectly the way it was until today.

    Cali wrote:

    Edit your village names, so instead of being 01Something, add a space so name now becomes 01 Something, the space acts as the 3rd character and should bring up your village name.
    I don't have numbers in my names and some names are maximum characters admitted. adding a space, messes up my names and also makes me to give up my last letter from the name.

    I'm starting to think about fixing old bugs, is better to just leave them be. Everybody is aware of them and i don't think i've been bothered about them.

    I'm Bothered now with the marketplace bug because it is part of the game that is actually affecting my gameplay and my playing time.
  • Cali wrote:

    Mysterious Stranger wrote:

    Marketplace is completely messed up. :thumbdown:

    When i select the destination village for sending resources, i need to type 3 letters instead of 2 to pop up the auto-complete.
    After i sent resources to that village, and select the next village to send resources from, i have to type the co-ords again and again for every single village i send resources from. This is driving me nuts.
    Edit your village names, so instead of being 01Something, add a space so name now becomes 01 Something, the space acts as the 3rd character and should bring up your village name.
    This still doesn't work. I have numbers on my villas but have to type the space in
    ukx - MadZ (Hegemony) | Danny Zuko (GTB)
    uk1 - David Brent (MFH)